1 頁 (共 1 頁)

關於 phpBB 3.0.12 升級到 phpBB 3.1.1 詢問

文章發表於 : 2014-11-10 12:54
變態怪叔叔
●主機作業系統:Linux (Fedora 14),自有電腦
●快速架站程式:無
●您的上網方式:中華電信 企業固定ip VDSL
●您安裝的程式:Apache v2.2.17 + php v5.3.8 + MySql v5.1.60
●您的 phpBB 版本:phpBB 3.0.12
●您的 domain (網域名稱) :暫不提供
●您的 phpBB 連結網址: 暫不提供

您好,先說個抱歉,因為論壇是公司內部使用,所以暫時無法提供網域及網址。

在下想提出的問題是,若論壇沒有裝任何外掛,僅使用基本功能,可以直接用AUTOMATIC UPDATE PACKAGE 3.0.12 to 3.1.1 的方式升級嘛?升級後還可以保持中文介面嘛?

備註:11/08才剛使用 AUTOMATIC UPDATE PACKAGE,從 2.0.23 升級到 3.0.12,升級過程沒有衝突及錯誤訊息。

Re: 關於 phpBB 3.0.12 升級到 phpBB 3.1.1 詢問

文章發表於 : 2014-11-11 08:32
心靈捕手
變態怪叔叔 寫:●主機作業系統:Linux (Fedora 14),自有電腦
●快速架站程式:無
●您的上網方式:中華電信 企業固定ip VDSL
●您安裝的程式:Apache v2.2.17 + php v5.3.8 + MySql v5.1.60
●您的 phpBB 版本:phpBB 3.0.12
●您的 domain (網域名稱) :暫不提供
●您的 phpBB 連結網址: 暫不提供

您好,先說個抱歉,因為論壇是公司內部使用,所以暫時無法提供網域及網址。

在下想提出的問題是,若論壇沒有裝任何外掛,僅使用基本功能,可以直接用AUTOMATIC UPDATE PACKAGE 3.0.12 to 3.1.1 的方式升級嘛?升級後還可以保持中文介面嘛?

備註:11/08才剛使用 AUTOMATIC UPDATE PACKAGE,從 2.0.23 升級到 3.0.12,升級過程沒有衝突及錯誤訊息。

從 2.0.23 升級到 3.0.12 是透過「轉換」的機制,沒有所謂的「AUTOMATIC UPDATE PACKAGE」。

升級到 3.1.1 後還可以保持中文介面,只是不完整。您必須更新中文化語言檔。

Re: 關於 phpBB 3.0.12 升級到 phpBB 3.1.1 詢問

文章發表於 : 2014-11-11 18:45
rex
因為架構上的不同,所以相關外掛功能將無法使用,
3.0.X 升級至 3.1.1 建議使用覆蓋升級的方式。

在竹貓尚未做出教學前,請先參考官方建議方式升級:
https://www.phpbb.com/support/docs/en/3 ... /upgrade3/

Ps. 如同捕手老師所言,在正體中文化尚未完成前需手動更新中文化語系檔。

Re: 關於 phpBB 3.0.12 升級到 phpBB 3.1.1 詢問

文章發表於 : 2014-11-11 20:33
變態怪叔叔
從 2.0.23 升級到 3.0.12 是透過「轉換」的機制,沒有所謂的「AUTOMATIC UPDATE PACKAGE」。

升級到 3.1.1 後還可以保持中文介面,只是不完整。您必須更新中文化語言檔。


感謝捕手老師提醒,我說錯了,我是從 2.0.23 「轉換」到 3.0.6,再使用「AUTOMATIC UPDATE PACKAGE」到 3.0.12 才對。

也謝謝 rex 大告知。

那我還是靜待 3.1.x 正體中文化的完成比較保險 (:Y)

Re: 關於 phpBB 3.0.12 升級到 phpBB 3.1.1 詢問

文章發表於 : 2014-11-15 15:35
心靈捕手
rex 寫:因為架構上的不同,所以相關外掛功能將無法使用,
3.0.X 升級至 3.1.1 建議使用覆蓋升級的方式。

在竹貓尚未做出教學前,請先參考官方建議方式升級:
https://www.phpbb.com/support/docs/en/3 ... /upgrade3/

Ps. 如同捕手老師所言,在正體中文化尚未完成前需手動更新中文化語系檔。

官方已經將 phpBB 3.0.x 升級至 phpBB 3.1.x 的自動升級包移除。 :-o

因為他們認為(如引言)直接覆蓋的方式比較適當。
參考連結:
https://www.phpbb.com/community/viewtop ... &t=2273976

因此,如果您的 phpBB 3.0.x 論壇有實在難以割捨的外掛,那麼不必急著升級;
也許有朝一日,該外掛的作者將它升級為適用 phpBB 3.1.x 的擴展功能,再說;
否則,升級至 phpBB 3.1.x 必須放棄現有外掛,並全面更新中文化語言檔才行。