突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/session

phpBB Installation & Usage Support
phpBB 3 安裝於各類型作業平台之問題討論;外掛問題,請到相關版面依發問格式發表!
(發表文章請按照公告格式發表,違者砍文)

版主: 版主管理群

版面規則
本區是討論關於 phpBB 3.0.X 架設安裝上的問題,只要有安裝任何外掛,請到外掛討論相關版面按照公告格式發表。
(發表文章請按照公告格式發表,違者砍文)
主題已鎖定
RayChang
星球普通子民
星球普通子民
文章: 4
註冊時間: 2009-06-08 09:12

突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/session

文章 RayChang »

今天突然發現,登入首頁的時候出現奇怪的錯誤訊息

[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /common.php:106)

請問有人知道這是怎麼回事嗎?
這段時間使用都很正常,雖然沒更新,但系統也沒出錯過,
不知道是哪裡有問題?會不會是被外人攻擊或入侵了?

●主機作業系統:記得是Linux
●快速架站程式:無
●免費(或付費)空間連結: 確認中
●您的上網方式:固網跟ADSL都試過
●您安裝的程式:付費網站空間架設的,非自行安裝
●您的 phpBB 版本:phpBB 3.0.X
●您的 domain (網域名稱) :star-angel.idv.tw
●您的 phpBB 連結網址: http://star-angel.idv.tw/

頭像
心靈捕手
默默耕耘的老師
默默耕耘的老師
文章: 8433
註冊時間: 2004-04-30 01:54
來自: Taiwan

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 心靈捕手 »

建議您:
檢視相關檔案的格式,是否為 UTF-8(未含 BOM)?

參考連結:
viewtopic.php?f=176&t=53615
施比受有福,歡迎來信賜教,謝謝 & 再見!
祝福您 好運 ^_^
歡迎加入★★心靈捕手★★ :: 討論區!!
http://wang5555.hopto.org/phpBB3/
p.s. 奉老婆之命:在晚上十一點前,得關機睡覺!!!

RayChang
星球普通子民
星球普通子民
文章: 4
註冊時間: 2009-06-08 09:12

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 RayChang »

這個檔案我沒有更動過,一直都運作正常,不知為何會突然跑出UTF-8的問題?
剛剛估狗了一下,有討論說可能被駭客攻擊過 @@

剛剛發現錯誤訊息沒有貼完整
Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/starange/public_html/phpBB3/common.php on line 106
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 916: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3537: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3539: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3540: Cannot modify header information - headers already sent by (output started at /common.php:106)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3541: Cannot modify header information - headers already sent by (output started at /common.php:106)

阿維
竹貓忠實會員
竹貓忠實會員
文章: 868
註冊時間: 2003-02-23 13:36
來自: 台南市

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 阿維 »

原則上 Deprecated: Function set_magic_quotes_runtime() 這個錯誤訊息,應該也可能跟 php 主機環境有關,因為 phpBB 官方也有人討論過類似的情況,只是我那時候沒有仔細看罷了。(請先將詳細的主機環境資訊提供上來吧)
提供代客維護 phpBB 3.0.x 以及外掛/風格升級或安裝的服務,如需委託,請與我聯絡,謝謝! ;)
我的 Skype 帳號:gpxjordan

御津闇慈
竹貓忠實會員
竹貓忠實會員
文章: 645
註冊時間: 2001-11-17 10:59

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 御津闇慈 »

請先用phpinfo()
檢查你的php版本
set_magic_quotes_runtime這函數在5.3以後已失效
http://php.net/manual/en/migration53.deprecated.php
PHPBB官方討論
http://www.phpbb.com/community/viewtopi ... &t=2091380

阿維
竹貓忠實會員
竹貓忠實會員
文章: 868
註冊時間: 2003-02-23 13:36
來自: 台南市

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 阿維 »

兄弟,你是說 php 5.3 嗎?這倒是在台灣的主機商環境很少看到的東西呢… :D
但除了提供 phpinfo() 的環境以供參考,我倒是覺得討論區版本也要升級一下,因為我看到的都是一些 phpBB 3.0.6 版本才會有這樣的情況,提供 RayChang 做參考。
提供代客維護 phpBB 3.0.x 以及外掛/風格升級或安裝的服務,如需委託,請與我聯絡,謝謝! ;)
我的 Skype 帳號:gpxjordan

御津闇慈
竹貓忠實會員
竹貓忠實會員
文章: 645
註冊時間: 2001-11-17 10:59

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 御津闇慈 »

3.07倒是有修正此問題
假如不想升級手動修正的話
應該是改
includes/startup.php
裡面有個
set_magic_quotes_runtime(0);
假如前面沒有@的話
前面標註一下吧
阿維 寫:兄弟,你是說 php 5.3 嗎?這倒是在台灣的主機商環境很少看到的東西呢… :D
但除了提供 phpinfo() 的環境以供參考,我倒是覺得討論區版本也要升級一下,因為我看到的都是一些 phpBB 3.0.6 版本才會有這樣的情況,提供 RayChang 做參考。
主機商大致上要升級的話要經過BOSS同意才能升級
因為
之前在舊版本可以執行的函數到了新版本就因為官方剔除導致運作不能的情況事情常常發生
我倒是相反=..=

原先在自己機器用的是新版本寫的程式
上線之後整個慘到不行

阿維
竹貓忠實會員
竹貓忠實會員
文章: 868
註冊時間: 2003-02-23 13:36
來自: 台南市

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 阿維 »

沒錯啊!所以我才說根本很難在台灣的主機環境上面看到 php 5.3.x 這個版本啊!
因為現在用的大多都是 php 5.2.x 甚至是 php 4.9.x 的環境,也是大有人在,可是偏偏各程式都紛紛調高可安裝的基本門檻到 php 5.2.14 以上的版本才能安裝,但位居更上層的 php 老大哥已經宣佈放棄支援 php 5.2.x 系列,還真是讓我們這些終端使用者陷入兩難啊!(說要升級也不是,不升級也不能用,真是傷腦筋呀!) (:H)
提供代客維護 phpBB 3.0.x 以及外掛/風格升級或安裝的服務,如需委託,請與我聯絡,謝謝! ;)
我的 Skype 帳號:gpxjordan

RayChang
星球普通子民
星球普通子民
文章: 4
註冊時間: 2009-06-08 09:12

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 RayChang »

謝謝各位大大說明
一語驚醒夢中人,
我剛剛檢查了一下,
架站server以前的PHP version是4.4.7
目前的確是升級到了5.3.8,難怪會出問題。

我有參照一些資料,將set_magic_quotes_runtime改掉了
錯誤訊息也沒了:)
只是原先預設style也不能用,囧
看起來有得搞了

御津闇慈
竹貓忠實會員
竹貓忠實會員
文章: 645
註冊時間: 2001-11-17 10:59

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 御津闇慈 »

阿維 寫:沒錯啊!所以我才說根本很難在台灣的主機環境上面看到 php 5.3.x 這個版本啊!
因為現在用的大多都是 php 5.2.x 甚至是 php 4.9.x 的環境,也是大有人在,可是偏偏各程式都紛紛調高可安裝的基本門檻到 php 5.2.14 以上的版本才能安裝,但位居更上層的 php 老大哥已經宣佈放棄支援 php 5.2.x 系列,還真是讓我們這些終端使用者陷入兩難啊!(說要升級也不是,不升級也不能用,真是傷腦筋呀!) (:H)
小心你被一堆主機商追殺一一

阿維
竹貓忠實會員
竹貓忠實會員
文章: 868
註冊時間: 2003-02-23 13:36
來自: 台南市

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 阿維 »

兄弟,你放心。
因為我也算是半個台灣虛擬主機商的從業人員,我只是說出身為從業人員對於安裝環境的無奈罷了,哪怕我只是個幫客戶安裝軟體的技術助理罷了,該面對現實的時候,還是要面對的。 :$ (這就是我們的無奈) :(
提供代客維護 phpBB 3.0.x 以及外掛/風格升級或安裝的服務,如需委託,請與我聯絡,謝謝! ;)
我的 Skype 帳號:gpxjordan

頭像
mdtom
星球公民
星球公民
文章: 256
註冊時間: 2010-01-17 04:03
來自: phpBB熱血鄉民團
聯繫:

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 mdtom »

御津闇慈 寫:
阿維 寫:沒錯啊!所以我才說根本很難在台灣的主機環境上面看到 php 5.3.x 這個版本啊!
因為現在用的大多都是 php 5.2.x 甚至是 php 4.9.x 的環境,也是大有人在,可是偏偏各程式都紛紛調高可安裝的基本門檻到 php 5.2.14 以上的版本才能安裝,但位居更上層的 php 老大哥已經宣佈放棄支援 php 5.2.x 系列,還真是讓我們這些終端使用者陷入兩難啊!(說要升級也不是,不升級也不能用,真是傷腦筋呀!) (:H)
小心你被一堆主機商追殺一一
我是比較好奇老大哥決定的理由...

因為在管理操作主機時
常會遇到要馬環境太舊,新套件裝不起來
要馬環境太新,舊套件裝不起來


最近裝一個Ruby的軟體裝到起笑還蠻有感的說...
● 主機作業系統:Linux
● 您的上網方式:kbroNet Cable
● 您安裝的程式:Apache 2.2.14 + php 5.3.2-1 + MySql 5.1.41-3
● 您的 phpBB 版本:phpBB 3.0.6
● 您的 domain (網域名稱) : tomy168.com
● 您的 phpBB 連結網址: 參見下方連結
》歡迎光臨我的 phpBB小站 / Tomy's Blog

架設論壇的目的是為了便利與服務網友
從心出發,沒有技術高低與門派之見!!

圖檔

御津闇慈
竹貓忠實會員
竹貓忠實會員
文章: 645
註冊時間: 2001-11-17 10:59

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 御津闇慈 »

mdtom 寫:
御津闇慈 寫:
阿維 寫:沒錯啊!所以我才說根本很難在台灣的主機環境上面看到 php 5.3.x 這個版本啊!
因為現在用的大多都是 php 5.2.x 甚至是 php 4.9.x 的環境,也是大有人在,可是偏偏各程式都紛紛調高可安裝的基本門檻到 php 5.2.14 以上的版本才能安裝,但位居更上層的 php 老大哥已經宣佈放棄支援 php 5.2.x 系列,還真是讓我們這些終端使用者陷入兩難啊!(說要升級也不是,不升級也不能用,真是傷腦筋呀!) (:H)
小心你被一堆主機商追殺一一
我是比較好奇老大哥決定的理由...

因為在管理操作主機時
常會遇到要馬環境太舊,新套件裝不起來
要馬環境太新,舊套件裝不起來


最近裝一個Ruby的軟體裝到起笑還蠻有感的說...
一一
說的也是

阿維
竹貓忠實會員
竹貓忠實會員
文章: 868
註冊時間: 2003-02-23 13:36
來自: 台南市

Re: 突然冒出的錯誤訊息[phpBB Debug] PHP Notice: in file /includes/ses

文章 阿維 »

簡單來說就是駭客入侵的猖獗才會導致 php 程式本身的進化,當然 php 本身功能的改進,這也是應該的。(有進步總是好的)

相較之下,我們倒是發現一些程式不論是主程式或擴充套件,還是死守在 php4 的版本,像這種我們大概就拒絕客戶了,因為 php4 真的很危險,根本不知道有哪種攻擊方式可以防範,我們能夠做的就是禁止使用罷了。(就像 OSC 2.2 MS 和 XOOPS 的擴充套件)
提供代客維護 phpBB 3.0.x 以及外掛/風格升級或安裝的服務,如需委託,請與我聯絡,謝謝! ;)
我的 Skype 帳號:gpxjordan

主題已鎖定

回到「[3.0.x] 安裝與使用」