[問題] WYSIWYG - Rich Text Editor 3.0 (所見即所得編輯介面)安裝問題

phpBB 2 MOD Support
無論是官方或非官方認證之外掛,安裝與使用問題討論。
(發表文章請按照公告格式發表,違者砍文)

版主: 版主管理群

主題已鎖定
JOM
星球普通子民
星球普通子民
文章: 13
註冊時間: 2005-11-25 13:11

[問題] WYSIWYG - Rich Text Editor 3.0 (所見即所得編輯介面)安裝問題

文章 JOM »

問題外掛:WYSIWYG - Rich Text Editor 3.0 (所見即所得編輯介面)
參考連結: http://phpbb-tw.net/phpbb/viewtopic.php?t=42226
使用版本:phpBB 2.0.21
狀況描述:

各位大大好,我是在安裝這個外掛時找不到原始碼中的字串
在這個外掛安裝說明中,有一段在檔案privmsg.php是:


#
#-----[ FIND around line number 1785 ]------------------------------------------
#


privmsg_subject = preg_replace($html_entities_match, $html_entities_replace, $privmsg_subject);
$privmsg_subject = str_replace('"', '"', $privmsg_subject);



紅色的這兩段我在privmsg.php此檔裡找不到,我以為是我有裝其他外掛的關係,但我去找剛裝好的檔案裡也找不到

只有找到類似的如下:

$privmsg_subject = ( ( !preg_match('/^Re:/', $privmsg['privmsgs_subject']) ) ? 'Re: ' : '' ) . $privmsg['privmsgs_subject'];
$privmsg_subject = preg_replace($orig_word, $replacement_word, $privmsg_subject);


而安裝檔後來的說明為:

#
#-----[ NEXT 2 LINE FIND ]------------------------------------------
#

$template->assign_vars(array(



這個因為之前的字串找不到,我也不知道它指的是那一行,因為後面有好幾行,
能否請有安裝成功的大大分享一下我是那邊有問題呢?謝謝

頭像
心靈捕手
默默耕耘的老師
默默耕耘的老師
文章: 8423
註冊時間: 2004-04-30 01:54
來自: Taiwan

文章 心靈捕手 »

這一段原始碼, 已經在後來升級 phpbb 2.0.20 時移除.

代碼: 選擇全部

#
#-----[ FIND ]---------------------------------------------
# Line 1743

	//
	// Send smilies to template
	//
	generate_smilies('inline', PAGE_PRIVMSGS);

#
#-----[ FIND ]---------------------------------------------
# Line 1748

	$privmsg_subject = preg_replace($html_entities_match, $html_entities_replace, $privmsg_subject);
	$privmsg_subject = str_replace('"', '"', $privmsg_subject);

#
#-----[ REPLACE WITH ]---------------------------------------------
# Just remove/delete the lines (replacing with an empty line)
Source: phpbb-2.0.19_to_2.0.20.txt

以下的修改, 提供您參考:

代碼: 選擇全部

# 
#-----[ FIND ]------------------------------------------ 
# 
	//
	// Send smilies to template
	//
	generate_smilies('inline', PAGE_PRIVMSGS);

# 
#-----[ AFTER, ADD ]------------------------------------------ 
# 

	//EDITOR START HERE 

	$privmsg_message = str_replace ("#ed_op#","<",$privmsg_message);
	$privmsg_message = str_replace ("#ed_cl#",">",$privmsg_message);
	$privmsg_message = str_replace ("&","&",$privmsg_message);
	$privmsg_message = str_replace('"',""",$privmsg_message);
	$privmsg_message = str_replace('\\',"&bkfls;",$privmsg_message);
	$privmsg_message = str_replace ("<br />","",$privmsg_message);

	$editor_off = get_global_var("editor_off");
	$richedit = get_global_var("richedit");
	$ua = get_global_var("user_agent");
	if ($richedit != "0") {
		$privmsg_message = str_replace("\r\n","<br />",$privmsg_message);
		$privmsg_message = str_replace("<br><br />","<br>",$privmsg_message);
	}
	if ($editor_off == "0" && strpos($ua,"Gecko") ){
		$privmsg_message = str_replace("<br />", "", $privmsg_message);
	}

	//EDITOR END HERE

# 
#-----[ NEXT 2 LINE FIND ]------------------------------------------ 
# 

	$template->assign_vars(array(

# 
#-----[ AFTER, ADD ]------------------------------------------ 
# 

	//EDITOR START HERE
	'DISPLAY_EDITOR_OPTION' => $display_editor_option,
	//EDITOR END HERE
ps.
因為 phpbb 版本更新, 所以所有的 'number' 只能當做是 '參考' 而已.
施比受有福,歡迎來信賜教,謝謝 & 再見!
祝福您 好運 ^_^
歡迎加入★★心靈捕手★★ :: 討論區!!
http://wang5555.hopto.org/phpBB3/
p.s. 奉老婆之命:在晚上十一點前,得關機睡覺!!!

JOM
星球普通子民
星球普通子民
文章: 13
註冊時間: 2005-11-25 13:11

文章 JOM »

謝謝心靈老師:)

不過你這一段在那邊有呀?
我在您提供下載的檔案裡面的mod_readme.txt裡面沒看到這一段呀
那是不是要請心靈大將此修正加入修訂呢?
這樣以後的人也有福囉:)

謝謝大大~我一路裝到最後,出現了一個問題

就是切換編輯器時會出現亂碼
(此為getvars.php此檔的問題,在英文時一切都正常,打上中文就變了樣)

我已經用convertZ轉成UTF-8檔了,當然此軟體裡的加BOM到UTF-8檔是沒打勾的
因為我也裝了一些外掛了,當然也都用此套轉過,都沒問題
這是IE下看的結果

圖檔

可是很奇怪的我在Firefox底下看就正常

圖檔

我是用winxp pro sp2
phpbb 2.0.21 (這已經是UTF-8版了呀)

我用的外掛:

1.虛擬貨幣 Cash Mod 2.2.3a
2.File Attachment Mod 2.4.3
3.管理員可收到新會員註冊通知 1.0.6(Admin Email Notification on New Registration)
4.進階版閃光會員名稱
5.Admin Userlist 管理員會員列表
6.會員列表顯示會員等級&等級圖示
7.Default Avatar MOD 預設頭像圖示


修正:

1.會員註冊寄信問題
2.用web mail收認證信會有亂碼情況
3.管理員可收到新會員註冊通知有亂碼情況


請問心靈大~這應該是什麼原因呢?

附上我的getvars.php

JOM
星球普通子民
星球普通子民
文章: 13
註冊時間: 2005-11-25 13:11

文章 JOM »

ok~~~自個來回一下

明明都有轉檔為何會失敗呢?
記得之前也有遇過~~倒底是什原因?
連我修改shoe_it.php檔把它轉為UTF-8也是有的有亂碼有的沒有,

因為小弟一直用Dreamweaver來編輯的(做網頁都用這個呀~)
就想不會是這個的問題吧~
把它換成UltraEdit來修改後,一切都正常了
我的DW有問題嗎?軟體內我也設定UTF-8檔了~
看來必須重灌或換最新版看看囉~~~
謝謝各位大大~~~

心靈大:記得把你前面講的修改給後面的人知道呀:)

主題已鎖定

回到「外掛問題討論」