[問題] phpMyAdmin始終無法使用..:(

phpMyAdmin Running Discuss
關於 phpMyAdmin 架設使用操作討論,非本程式相關問題一律砍文!

版主: 版主管理群

talazer
星球普通子民
星球普通子民
文章: 1
註冊時間: 2005-02-01 22:44
來自: Canada

文章 talazer » 2005-02-02 02:02

按照小竹子的phpMyAdmin进入教程, 只有2.4.1的appserv可行。

xeasys
星球普通子民
星球普通子民
文章: 4
註冊時間: 2003-07-05 09:50

文章 xeasys » 2005-02-03 11:27

對大家遇到的密碼問題... 我的解決方法
主目錄登出系統上方的更改密碼,選MySQL 4.0相容...
這樣就沒問題了,希望對大家有一點幫助^^

P.s 要改帳號 要先用那個帳號登入...
P.s 別用權限裡面的改密碼^^

註:Appserv 2.4.3 phpMyAdmin...

callme
星球普通子民
星球普通子民
文章: 4
註冊時間: 2004-10-10 21:33
來自: 台灣
聯繫:

文章 callme » 2005-03-21 17:14

talazer 寫:按照小竹子的phpMyAdmin入教程, 只有2.4.1的appserv可行。
我也預到相同的問題
下載 appserv 最新的 2.4.3
依照小竹子的教學法會有先前大家出現的無法登入的毛病
但換回 2.4.1 就可以正常運行了
(小竹子當年寫的時候 是針對 2.3.0 版本寫的
所以軟體更新會有些衝突 我想也無可厚非)

前前後後reinstall了將近有50次... :evil:
提供給大家作為參考 希望可以節省一些無謂的時間... :-P

aHfUi
星球公民
星球公民
文章: 184
註冊時間: 2004-11-14 17:52
聯繫:

文章 aHfUi » 2005-03-21 21:08

那麼到最後怎樣 ?
我安裝2.4.2的時候也差不多那麼多次\r
可是到現在還是登入失敗
現在放棄了 @@"""
哈哈哈哈哈哈

~倉木麻衣~
竹貓忠實會員
竹貓忠實會員
文章: 1407
註冊時間: 2004-03-21 21:00

文章 ~倉木麻衣~ » 2005-03-21 22:09

aHfUi 寫:那麼到最後怎樣 ?
我安裝2.4.2的時候也差不多那麼多次\r
可是到現在還是登入失敗
現在放棄了 @@"""
哈哈哈哈哈哈
看過這篇的話~應該就沒有那麼多問題了 :mrgreen:

頭像
招才貓
星球普通子民
星球普通子民
文章: 2
註冊時間: 2002-10-14 09:23

[討論] 我也是遇到這樣的問題,不過有另外的解法!!

文章 招才貓 » 2005-04-13 09:41

phpMyadmin的說明原文提到(中文):
[4.4] phpMyAdmin always gives "Access denied" when using HTTP authentication.
(phpMyAdmini在HTTP驗證模式下一直出現權限錯誤)
This could happen for several reasons:
(可能有以下原因)

$cfg['Servers'][$i]['controluser'] and/or $cfg['Servers'][$i]['controlpass'] are wrong.
($cfg['Servers'][$i]['controluser']和$cfg['Servers'][$i]['controlpass'] 設定錯誤)
The username/password you specify in the login-dialog are invalid.
(帳號密碼輸入錯誤)
You have already setup a security mechanism for the phpMyAdmin-directory, eg. a .htaccess file. This would interfere with phpMyAdmin's authentication, so remove it.
(你可能將phpMyAdmin的目錄設定其他權限,例如.htaccess檔案,這樣會影響到phpMyadmin的認證,所以請移除)

後來我發現我的設定都是正確的,但是在IIS的資料夾的權限設定是錯的,我想也許apache也是一樣,請參考看看

Jone
星球普通子民
星球普通子民
文章: 10
註冊時間: 2002-11-24 21:01

文章 Jone » 2005-04-15 21:22

~倉木麻衣~ 寫:
aHfUi 寫:那麼到最後怎樣 ?
我安裝2.4.2的時候也差不多那麼多次\r
可是到現在還是登入失敗
現在放棄了 @@"""
哈哈哈哈哈哈
看過這篇的話~應該就沒有那麼多問題了 :mrgreen:
剛想升級也愈到這個情形 請問一下各位大大喔

目前最好的版本是2.4.1嗎? 我很怕用了2.4.3 之後還有一堆問題 >_<

不如用舊的版本 :roll:

tastegood
星球普通子民
星球普通子民
文章: 9
註冊時間: 2005-04-15 22:20

文章 tastegood » 2005-04-16 01:38

2.4.3安裝的時候只問你伺服器位置跟信箱
沒有問你mysql的帳號密碼,之後就直接安裝了
安裝完畢之後要連到phpMyadmin時,就出錯了....

另外問一下可不要移除2.4.0直接安裝2.4.1覆蓋嗎?
●架設主機作業系統:Windows xp
●快速架站程式:Appserv v2.4.0
●免費空間連結:架在本電腦上
●我的上網方式:ADSL 浮動 IP
●我安裝的程式:Apache + php + MySql
●我的 phpBB2 版本:phpBB 2.0.14
●我的 phpBB2 連結網址: http://roup.dynalias.com/phpbb2/index.php
●我安裝過的外掛:文字氣泡,EasyMOD,金錢MOD
●我使用的風格:whatisreal

novajiang
星球普通子民
星球普通子民
文章: 9
註冊時間: 2005-03-01 17:01

[建議] Linux Fedora 3 MySQL 無法連結

文章 novajiang » 2005-04-18 08:28

發生下列的 Error 訊息.
#2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'

我在網路上找到一篇討論. 需要修改 SELinux 的設定。
我更改後 phpMyAdmin 就可以連結 mysql 。
但安全性降低的作法似乎不是很好,最終解決方案我看不懂,有那位高手看過後再跟大家說明一下吧.

Source :
http://forums.devshed.com/t14130/s.html

------------------------------------
I have been having the same problem and I have found the solution -- at least for me. The problem for me is that I had just installed Fedora Core 3. Starting with Fedora Core 3, SELinux is turned on by default. SELinux is the Secure Edition that has extra security features. I turned SELinux off and I stopped getting the error. I will do some more research and see if I can just turn off parts of SELinux to get MySQL to work with PHP and Apache.

-------------------------------------
this is the procedure I've followed to configure SELinux :

代碼: 選擇全部

From Startmenu select
"System settings"
Then choose
\n"Security settings or security level"
A window appears with 2 tabs : "Firewall options" and "SELinux"
Choose SELinux.
At the bottom half of the window you have a lisbox, listing (at least on my PC)

HTTPD Service
Name Service
NIS
SELinux Service Protection

Open SELinux Service Protection
Select "Disable SELinux protection for mysqld daemon"
Click "OK"

Open HTTPD Service
Select "Disable SELinux protection for httpd daemon"
Click "OK"

-----------------------------------------
In my Fedora Core 3 (in which I have already run "fixfiles reset"), I was able to get a PHP call to mysql_connect() working by just disabling the SELinux protection of the httpd daemon (as described in the previous submission to this thread). I left the protection of the mysql daemon running. Then:

# /etc/init.d/httpd restart
# /etc/init.d/mysqld restart (for good measure, probably not necessary)
Now things work (without the reboot mentioned in the previous contribution).

Hope this narrows things down.

Also, see next post for the *REAL* fix.
------------------------------------------------------------------------

The *REAL* fix
This problem was hashed out in a fairly readable way in the RedHat fedora-selinux-list forum. The initial post is now at

https://www.redhat.com/archives/fedora- ... 00013.html

You'll want to read most of the followups.

The preferred solution involves creating an selinux domain, "mysqld_t," that has permission to read and write a particular socket. Manipulating selinux sounds hairy, but the instructions are fairly straightforward. The correct solution is the first one suggested in

https://www.redhat.com/archives/fedora- ... 00015.html

NB: the line that reads:
* service mysql restart
should read:
* service mysqld restart

good luck!
最後由 novajiang 於 2005-04-20 09:17 編輯,總共編輯了 1 次。

無敵肉腳
星球公民
星球公民
文章: 91
註冊時間: 2004-03-05 16:59
來自: 太平洋區-沙庫索島

文章 無敵肉腳 » 2005-04-19 00:21

我也是\r
使用了最新的apps....
只要到了修改使用者....
就會沒法登錄進phpmyadmin
重新裝了有....快30次.....
這部份沒弄好...是沒法裝phpbb2的
大家都是想要伺服更安全點才會想到要裝新一點的apps.
只要你不做任何的帳號修改....是可以使用...
但是這樣子...不就比微軟還要差....是差到底了......有架跟沒架是一個意思!


我也快放棄....
我先去熊蓋站那問問...
那邊學生多...
玩的人多..
講師也較多(學生)
可能比較有時間玩到apps最新的....
我去問問看他們會有什麼解決方案
圖檔

RogerShih
星球普通子民
星球普通子民
文章: 2
註冊時間: 2002-11-22 00:15
來自: 地球
聯繫:

文章 RogerShih » 2005-04-19 23:26

錯誤!!刪!!

原來我在公司有把舊的 mysql 帳號資料庫蓋過新的.= =

頭像
alrex5401
星球普通子民
星球普通子民
文章: 8
註冊時間: 2003-08-29 10:58
來自: 天堂地獄
聯繫:

文章 alrex5401 » 2005-04-25 01:33

最終還是無解嗎=.=
害我剛重拾一年前的熱情~
又快要滅掉嚕~
剛解決完PHP問題
現在SQL又有問題QQ

小白鮪魚肚
星球普通子民
星球普通子民
文章: 5
註冊時間: 2005-03-27 17:02

文章 小白鮪魚肚 » 2005-04-25 16:07

那要如何 重置 phpMyAdmin 的線上人數&時間阿??

hollowaysxp
竹貓忠實會員
竹貓忠實會員
文章: 535
註冊時間: 2004-06-01 22:39
來自: 仙境傳說回憶最美~台灣桃園
聯繫:

Re: [問題] 我的也是

文章 hollowaysxp » 2005-06-04 23:07

alexday 寫:Dear all
os:linux fredoa 3(可能打錯 請包含)
沒想到 也是有人和我有相同問題.
太 了~了,但我看了一下~ 也是沒有答案 說怎麼解

請大大給我解決方法~~
3q
FC3內建的Mysql不太可能,因為FC3的Mysql是3.x版。
除非你自己裝4.1.x
●架設主機作業系統:FreeBSD 6.2-RELEASE (自行架設)
●我的上網方式:FTTB+VDSL HINET 10M/2M
●我安裝的程式:Apache 2.0.59+ PHP Version 4.4.4 + MySql 4.1.21+phpMyadmin 2.9.1.1
●我的 phpBB3 版本:phpBB3.0.1
●我的 phpBB3 連結網址 http://nitcs.itrello.com/forum/
NITCS歡迎你
NITCS論壇

lis
星球普通子民
星球普通子民
文章: 8
註冊時間: 2003-11-22 20:41

Re: [建議] Linux Fedora 3 MySQL 無法連結

文章 lis » 2005-08-06 11:38

[quote="novajiang"]發生下列的 Error 訊息.
#2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'

我在網路上找到一篇討論. 需要修改 SELinux 的設定。
我更改後 phpMyAdmin 就可以連結 mysql 。
但安全性降低的作法似乎不是很好,最終解決方案我看不懂,有那位高手看過後再跟大家說明一下吧.

Source :
http://forums.devshed.com/t14130/s.html


在linux下試試執行以下指令\r
setsebool -P mysqld_disable-trans=1
上面的說明是圖形介面的作法

回覆文章

回到「phpMyAdmin」