1 頁 (共 8 頁)

PHP (動態網頁腳本語言) (Update 7.3.5 / 7.2.18 / 7.1.29)

發表於 : 2007-09-03 21:39
心靈捕手
軟體簡介:
PHP 是一種新型的 CGI 程式編寫語言,易學易用,可以方便快捷地編寫出功能強大,運行速度快,並可同時運行於Windows、Unix、Linux 平臺的 Web 後臺程式,內置了對文件上傳、密碼認證、Cookies 操作、郵件收發、 動態 GIF 生成等功能,PHP3 直接為很多資料庫提供原本的連接,包括 Oracle、Sybase、Postgres、Mysql、Informix、Dbase、Solid、Access 等,完全支援 ODBC 介面。

--
資料來源:
http://www.softking.com.tw/soft/clickco ... fid3=25109

--
參考連結: --
釋出已經好幾天了! :oops:

由於 PHP 4.x 即將於 2007-12-31 停止支援,
所以官方建議大家, 適時升級您的 PHP 版本為 5.x.

PHP 4 end of life announcement

[13-Jul-2007]
Today it is exactly three years ago since PHP 5 has been released. In those three years it has seen many improvements over PHP 4. PHP 5 is fast, stable & production-ready and as PHP 6 is on the way, PHP 4 will be discontinued.

The PHP development team hereby announces that support for PHP 4 will continue until the end of this year only. After 2007-12-31 there will be no more releases of PHP 4.4. We will continue to make critical security fixes available on a case-by-case basis until 2008-08-08. Please use the rest of this year to make your application suitable to run on PHP 5.
Source: http://www.php.net/

Download: http://www.php.net/downloads.php

--
P.S.
最新版本, 請參考最後一篇文章.

發表於 : 2007-09-04 00:12
jwxinst
看來我們的主機也要升級一下囉-.-
目前我已經借了PHP5的書來看看
其實之前在寫smarty的時候
就已經有部份的code是與PHP4不適合
只好改一改就成功, HAHAHA


不過像XAMPP這類東西, 都已經可以PHP4 / PHP5 switch
又是自架主機 / localhost測試, 的確是一件好事
畢竟測試時你可以去看看PHP4和5跑下來的效果和錯誤

發表於 : 2007-09-05 08:43
心靈捕手
jwxinst 寫:看來我們的主機也要升級一下囉-.-
目前我已經借了PHP5的書來看看
其實之前在寫smarty的時候
就已經有部份的code是與PHP4不適合
只好改一改就成功, HAHAHA


不過像XAMPP這類東西, 都已經可以PHP4 / PHP5 switch
又是自架主機 / localhost測試, 的確是一件好事
畢竟測試時你可以去看看PHP4和5跑下來的效果和錯誤
不太理解為何 '主機也要升級'? :-?

依我的經驗, 無論是 PHP5.0.X 或者是 PHP5.2.x, Apache 都是可以跑的.
重點在於做好 httpd.conf, php.ini 的相關設定

早點升級是比較建議的!
因為 PHP5 比較快速與穩定;
比較容易出錯的是, 很可能有部分功能的語法, 到了 PHP5 時, 已經有更動;
必須要除錯, 或者是改用其他語法替代.

--
再補一則官方訊息:
PHP 4.4.7
Support for PHP 4 will be discontinued at 2007-12-31. Please consider upgrading to PHP 5.2.
Source: http://www.php.net/downloads.php

發表於 : 2007-09-05 15:09
computer315
更新了...多謝分享
心靈捕手 寫:
jwxinst 寫:看來我們的主機也要升級一下囉-.-
目前我已經借了PHP5的書來看看
其實之前在寫smarty的時候
就已經有部份的code是與PHP4不適合
只好改一改就成功, HAHAHA


不過像XAMPP這類東西, 都已經可以PHP4 / PHP5 switch
又是自架主機 / localhost測試, 的確是一件好事
畢竟測試時你可以去看看PHP4和5跑下來的效果和錯誤
不太理解為何 '主機也要升級'? :-?
他說的應該是主機的php要升級吧=.=
美式中文有點怪怪的XD

[建議] 安裝或升級最新 5.2.5 版

發表於 : 2007-11-11 19:44
心靈捕手

[建議] 安裝或升級最新 5.2.6 版

發表於 : 2008-05-03 13:04
心靈捕手
PHP: Downloads
http://www.php.net/downloads.php

PHP: PHP 5 ChangeLog
http://www.php.net/ChangeLog-5.php

--
建議您:
適時的升級.

[建議] 安裝或升級最新 5.2.7 版

發表於 : 2008-12-05 22:38
心靈捕手
PHP: Downloads
http://www.php.net/downloads.php

PHP: PHP 5 ChangeLog
http://www.php.net/ChangeLog-5.php

--
建議您:
適時的升級.

P.S.
這 5.2.6 PECL 包仍可適用 PHP 5.2.7, 無須更新.

Re: [新聞] PHP (Update 5.2.7)

發表於 : 2008-12-09 01:01
lin7
PHP官方剛剛在上周發佈了5.2.7並在首頁上更新,今天就撤下了這條消息,原因很簡單,在5.2.7中發現了一個magic_quotes_gpc的嚴重bug.所以發佈了5.2.8.

當然您可能剛剛升級您的站點到5.2.7,不過個人覺得這到是PHP或開源負責任的態度。

對比5.2.7只有下面一條修正:

08 Dec 2008, PHP 5.2.8

- Reverted bug fix #42718 that broke magic_quotes_gpc (Scott)



PHP 5.2.8

http://us2.php.net/distributions/php-5.2.8.tar.bz2

Re: [新聞] PHP (Update 5.2.7)

發表於 : 2008-12-09 21:52
心靈捕手
lin7 寫:PHP官方剛剛在上周發佈了5.2.7並在首頁上更新,今天就撤下了這條消息,原因很簡單,在5.2.7中發現了一個magic_quotes_gpc的嚴重bug.所以發佈了5.2.8.

當然您可能剛剛升級您的站點到5.2.7,不過個人覺得這到是PHP或開源負責任的態度。

對比5.2.7只有下面一條修正:

08 Dec 2008, PHP 5.2.8

- Reverted bug fix #42718 that broke magic_quotes_gpc (Scott)



PHP 5.2.8

http://us2.php.net/distributions/php-5.2.8.tar.bz2
感謝分享!

1. 相關檔案, 還是直接到官方網站去下載為宜.
http://www.php.net/downloads.php
2. 這 5.2.6 PECL 包仍可適用 PHP 5.2.8, 無須更新.

[建議] 安裝或升級最新 5.2.9 版

發表於 : 2009-02-27 22:52
心靈捕手
PHP: Downloads
http://www.php.net/downloads.php

PHP: PHP 5 ChangeLog
http://www.php.net/ChangeLog-5.php

--
建議您:
適時的升級.

P.S.
這 5.2.6 PECL 包仍可適用 PHP 5.2.9, 無須更新.

[建議] 安裝或升級最新 PHP 5.2.9-1 (for Windows) 版

發表於 : 2009-03-11 21:31
心靈捕手
這個最新 PHP 5.2.9-1 版, 只有作業系統為 Windows 者適用.
主要是修正 cURL 安全性問題, 詳情參閱底下.
http://curl.haxx.se/docs/adv_20090303.html

PHP: Downloads
http://www.php.net/downloads.php

[建議] 安裝或升級最新 PHP 5.2.9-2 (for Windows) 版

發表於 : 2009-04-11 09:53
心靈捕手
這個最新 PHP 5.2.9-2 版 (只有作業系統為 Windows 者適用),
主要是修正 OpenSSL 安全性問題, 詳情參閱底下.
http://openssl.org/news/secadv_20090325.txt

PHP: Downloads
http://www.php.net/downloads.php

[新聞] PHP (動態網頁腳本語言) (Update 5.2.10)

發表於 : 2009-06-24 22:43
心靈捕手
PHP: Downloads
http://www.php.net/downloads.php

PHP: PHP 5 ChangeLog
http://www.php.net/ChangeLog-5.php

--
建議您:
適時的升級.

P.S.
這 5.2.6 PECL 包仍可適用 PHP 5.2.10, 無須更新.

[新聞] PHP (動態網頁腳本語言) (Update 5.3.0)

發表於 : 2009-07-03 08:23
心靈捕手
最新版本: 5.3.0

PHP: Downloads
http://www.php.net/downloads.php

PHP: PHP 5 ChangeLog
http://www.php.net/ChangeLog-5.php

--
個人一直無法順利使用此更新版; 連至論壇, 會出現下列錯誤訊息:

代碼: 選擇全部

General Error
SQL ERROR [ mysql4 ]

mysqlnd cannot connect to MySQL 4.1+ using old authentication [2000]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
建議您:
備份後, 再適時的升級.

Re: [新聞] PHP (動態網頁腳本語言) (Update 5.3.0)

發表於 : 2009-07-07 22:39
心靈捕手
心靈捕手 寫:最新版本: 5.3.0

PHP: Downloads
http://www.php.net/downloads.php

PHP: PHP 5 ChangeLog
http://www.php.net/ChangeLog-5.php

--
個人一直無法順利使用此更新版; 連至論壇, 會出現下列錯誤訊息:

代碼: 選擇全部

General Error
SQL ERROR [ mysql4 ]

mysqlnd cannot connect to MySQL 4.1+ using old authentication [2000]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
建議您:
備份後, 再適時的升級.
這個錯誤的解決, 必須進資料庫, 更新管理者的密碼格式為 41 位元加密字符.

參考連結:
http://phpbb-tw.net/phpbb/viewtopic.php ... 65#p272665